# Table of Contents

Chapter 1 - Getting Started ................................................................................................................................. 3  
  **Overview** ......................................................................................................................................................... 3  
  **What is a Content Management System?** ........................................................................................................ 3  
  **Requirements** ................................................................................................................................................... 3  
  **Cascade Server Terminology** .......................................................................................................................... 3  
  **Logging into Cascade Server** .......................................................................................................................... 4  
  **Top Menu Bar** ................................................................................................................................................... 4  
  **The Dashboard** .................................................................................................................................................. 4  
  **The Asset Tree** ................................................................................................................................................ 5  
  **Asset Options** .................................................................................................................................................. 6  

Chapter 2 - Asset Creation ........................................................................................................................................... 6  
  **Creating Assets** .................................................................................................................................................. 6  
  **The Universal Page Template** ....................................................................................................................... 7  
  **Creating a Universal Page** .............................................................................................................................. 7  
  **Creating Universal Page Content** .................................................................................................................. 8  

Chapter 3 - Files and Folders ....................................................................................................................... 9  
  **Creating Files** .................................................................................................................................................. 9  
  **Creating Folders** .............................................................................................................................................. 9  

Chapter 4 - Images and Links ............................................................................................................................ 11  
  **Inserting Images** .............................................................................................................................................. 11  
    - Inserting an image (internal or external) into existing content .................................................................. 11  
    - Advanced Image Attributes ......................................................................................................................... 11  
  **Image Specifications** ....................................................................................................................................... 11  

Chapter 5 - Links .................................................................................................................................................... 13  
  **Inserting Links and Linked Email Addresses** ............................................................................................... 13  
    - Inserting an internal or external link into the main area .............................................................................. 13  
    - Inserting an email address into existing text ............................................................................................... 13  

Chapter 6 - Navigation .......................................................................................................................................... 14  
  **Navigational Relationships** ............................................................................................................................ 14  
  **Managing Navigation** ..................................................................................................................................... 15  
    - Editing the Sort Order of the Left Navigation .............................................................................................. 15
Showing/Hiding the Left Navigation................................................................. 15
Showing/Hiding individual pages in the Left Navigation.............................. 15
Chapter 7 - Publishing..................................................................................... 16
  Publishing Assets (for Coordinators) ............................................................. 16
  Un-publishing Assets.................................................................................... 16
  Un-indexing Assets...................................................................................... 16
Chapter 8 - Glossary....................................................................................... 17
  Glossary of Terms....................................................................................... 17
Chapter 1 - Getting Started

Overview
This document provides an overview of the editing of a basic web page, as well as referencing existing external components for these page types using the Cascade Server Content Management System (CMS) by Hannon Hill for the http://www.ncat.edu website.

What is a Content Management System?
A content management system (CMS) is a computer application that supports the creation and modification of digital content using a common user interface and thus usually supporting multiple users working in a collaborative environment.

Requirements
Only University Relations approved content coordinators and contributors can obtain access to the CMS. The department’s content coordinator can request content contributor access with department head approval.

Cascade Server offers full support for the following major browsers, including: Internet Explorer 7+, Mozilla Firefox 4+, Safari 3+ and Google Chrome.

Cascade Server Terminology
Here are some frequently used terms this guide may reference while discussing the Cascade Server CMS:

- **Asset** – any entity within Cascade Server.
- **Asset Factory** – used to create every asset in Cascade Server. Asset Factories are similar in function to Microsoft Word templates.
- **File** – any asset in the system that is not created from other assets, such as images, sounds, and video.
- **Block** – the basic building element of Cascade Server. Blocks can be placed within pages to generate content. Blocks are the smallest container for content in Cascade Server.
- **Page** – the main content container in Cascade Server. Pages are created from blocks and files and can be published in various formats, such as web pages, PDFs, and XML documents.
- **External Link** – a symbolic link stored in Cascade Server to point to a specific URL outside of Cascade Server.
- **Folder** – a container to organize and store assets.
- **Lock** – a way to prevent editing of an asset by anyone but yourself.
- **Draft** – an unfinished document that’s been saved but not pushed into a workflow or published.
- **Workflow** – a process of approval a document must pass through before it is published.
Logging into Cascade Server
The website URL to log into the Cascade Server is [http://cascade.ncat.edu](http://cascade.ncat.edu). This default page should display a login dialog.

To log in, enter your N.C. A&T OneID Username and Password, and click Log in to Cascade Server. If you have problems accessing the CMS please contact Aggie Tech Support at [http://www.ncat.edu/divisions/doit/dept/ats/](http://www.ncat.edu/divisions/doit/dept/ats/).

On successful login, you will be taken your dashboard. Please verify that the dropdown box next to the Cascade Server logo has NCAT.edu selected to view assets. Depending on your access level, some functionality may be hidden.

Top Menu Bar

To return to the Dashboard from anywhere in the CMS, click on the stylized Capital C, on the upper left toolbar If you have access to more than one Site, click on the SITE: dropdown to select your site. Most N.C. A&T Users will just have the NCAT.edu site.

On the upper right, is My Content with the similar sections provided by the widget, Search, Personal Settings and the three lined “hamburger” menu

The Dashboard

The dashboard is comprised of several widgets including:

- **My Sites** – websites in the CMS you have access to
- **My Content** – Content you have created or are responsible for including
  - **Recent** – the most recent items you have edited and submitted
  - **Owned Content** – assets you have created
  - **Drafts** – content you have edited but not submitted
  - **Workflows** – If your site is in a workflow, assets that require your approval
  - **Locks** – assets that you have locked out to prevent others from editing
- **My Upcoming Tasks** – Listing of Tasks if assigned with due dates
- **Messages** – system status messages and comment and task notifications
- **Stale Content** – a graph and count of assets that were updated with 60 days or longer
- **Content To Review** – if assets were tagged for review, a list of assets that fit the criteria
The Asset Tree

Cascade Server refers to any component used to generate content as **assets**. For example all pages, files, blocks, style sheets, external links, folders, templates and references are all considered assets.

The **asset tree** is used to locate and select assets, under the **SITE CONTENT** banner. The tree displays the folder navigation and a hierarchical menu of the website’s assets. By default folders are **collapsed**. On mouse pointer hover, a ➕ symbol appears. Clicking on the folder expands / contracts the folder depending on its current state but does not load the folder. To navigate to the folder, click the ➕. Expanded folders are designated by a minus sign (⁻) icon. Clicking on the icon changes the folder’s state.

To select an asset to view or edit, click on the asset’s name. The main panel updates to reflect the context of the asset.
Right clicking on assets shows operation in the asset tree. Depending on your access level and the type of asset, they will consist of a subset of:

- **View** – Displays preview of the asset
- **Edit** - Content entry and other asset attribute changes
- **Publish** – push the asset to the live website
- **Move** - move asset to different folder IMPORTANT – ensure Unpublish Content is checked
- **Rename** – changes asset name IMPORTANT – ensure Unpublish Content is checked
- **Copy** – create a new asset from an existing asset
- **Delete** - IMPORTANT – ensure Unpublish Content is checked
- **Unpublish** – removes the asset from the live website but keeps in the CMS
- **Access** – Read write permission for assets
- **Check-out/ Lock** – assets can be locked if multiple users access
- **Relationships** - when assets (the "referring assets") refer to another asset (the "related asset").
- **Audits** - log of actions performed by users on the asset
- **Versions** – the last 20 versions of asset can be viewed or restored
- **Reference** – list of assets that link to the asset in the CMS
- **Tasks**
- **Schedule Review**
- **Mark As Reviewed**

Chapter 2 - Asset Creation

Creating Assets

New content in the CMS is created by using Asset Factories, to create a new web page from an NCAT.edu template, in the menu bar, you would select Add Content and the appropriate template for your type of content.

Non-Template Items such as Blocks, External Links, and Folders such as documents such as images are under Default and the majority of static N.C. A&T templates are under NCAT.edu.

Content pages are created in a hierarchy called Information Architecture (IA) and are reflected in the Asset Tree. The top level pages and folders of the IA have been created in the system as specified by University Relations.

As new folders and pages are created to build out the site content, their asset names will become
the URL to link to the pages on the site. For example, the ‘index’ page in the ‘about’ folder will be visible when published to the site at the URL http://www.ncat.edu/about/index.html.

The Universal Page Template
The Universal Subpage template will be the most common page type used on the site. It is the standard content page that will make up a majority of pages on the site. The Universal Subpage can be configured to display with a 1, 2, or 3 columns.

Creating a Universal Page
Universal Pages can be created by selecting Add Content > NCAT.edu > Universal Page

This will bring up the New Page Content Creation panel.
Creating Universal Page Content

In the Content tab

The interface asks for Display Name, which will be the name of the asset, will appear in the page’s navigation, breadcrumbs and as part of the page’s URL. Giving the page a short accurate description will help with Search Engine Optimization.

Be mindful of the Placement Folder. This is where the document lives.

The Title field should be the page’s title and will appear as a header on the page, and in the browser’s title.

The Main Image, if used, should be exactly 750 pixels (px) × 341px, at 72 dpi (dots per inch) resolution. The aspect ratio should be in the correct proportion. Subjects looking flattened or narrowed are unacceptable.

The Main Content area in the CMS is a rich text content editor or WYSIWYG (“What You See Is What You Get” editor. This editor has many features built into the toolbar similar to other word processing tools such as Microsoft Word™:
The WYSIWYG rich text editor creates formatted HTML for you. HTML is not required for editing content but knowledge of it is helpful.

The <> button lets you access the HTML editor if edits need to be made at that level. For reference here are some guides that show correct HTML formatting:


---

**Chapter 3 - Files and Folders**

**Creating Files**

To add your existing files such as images or documents to Cascade Server, they need to be created as new assets, and then uploaded to the CMS. In the menu to create these assets, select **Add Content > Default > File** in the menu bar.

Files can be dragged from your computer’s file interface and dropped onto the dotted-line area. The **Preview** tab shows a preview of the asset.

The **File Name** will be populated with the name of the uploaded file, which is required. Renaming the file is optional but can be done here. The document type should remain the same.

The **Title** field will be blank but requires completion for file creation. Please provide a descriptive title for the asset. The Title provides data about the asset, or *Metadata*, which helps Search Engine Optimization.

Selecting **Submit** creates the asset in the CMS.

---

**Creating Folders**

To create folders is a similar process as creating files. In the menu to create these assets, select **Add Content > Default > Folder** in the menu bar. The **Folder Name** is the name of the folder in the asset tree.
The Display Name, the name of the asset, will appear in the page’s left navigation, breadcrumbs and as part of the page’s URL. Giving the page a short accurate description will help with Search Engine Optimization.

The **Title** field should be the landing page’s title and will appear as a header on the page, and in the browser’s title.

*It is required that in Cascade Server as each folder is created, a page with the System Name *index* with landing page content.*
Chapter 4 - Images and Links

Inserting Images

These instructions are applicable across multiple template types.

Inserting an image (internal or external) into existing content
- Select a page from the asset tree
- Click the “Edit” tab.
- Locate the Rich Text Editor and select the text you would like to add an image.
- Select the Insert/Edit image icon available in the WYSIWYG editor. The Insert/Edit image dialog box will appear.
- Select the Internal or External check box.
- Navigate to the Internal file
- Paste the Link to the external file
- Enter a Title which would be the alt tag and appear when a user hovers over the link.
- Click “Insert”

Advanced Image Attributes

Note: For additional options as far as image alignment, under the advanced tab are settings for Alignment, Border Width, Vertical Spacing and Horizon Spacing.

Image Specifications

Color Space: RGB
Resolution: 72 dpi
Image format: jpg. Average to better image quality.

Frequently Used Image Dimensions
- Department Rich Page Main image: 744px x 307px
- Universal Paige Main image: 750px x 341px
- Special Interest Left Feature image 175px x 110px or 175px x 101px
- Right Inset image 225px x 150px
- Inset interview image at bottom: 225px x 225px
• Points of pride image at bottom: 95px × 65px
• Alumni gateway: 551px × 368px
• News Articles: 175px × 250px
• Thumbnail Images: 130px × 87px
• Admissions Arrows: 551px × 319px
• Undergrad Admissions Images: 551px × 319px
• Excellence Page Front: 450px × 300px
  o Inner: 225px × 150px
• Board of Dir. Images: 115px × 146px
• Homepage Profiles: 560px × 450px
• Homepage “Latest” rectangle image: 189px × 107px
• News Thumbnail: 130px × 100 or 130px × 89px
• News Article Image: 713px × 341px (750px × 341px)
  o Portrait: 256px × 341px
• Left Feature image: 175px × 192px
  o Thumbnail: 130px × 83px
• Photo Gallery: 500px × 380px (must be less than on each)
Chapter 5 - Links

Inserting Links and Linked Email Addresses

Inserting an internal or external link into the main area

- Select a page from the asset tree
- Click the “Edit” tab.
- Locate the Rich Text Editor and select the text you would like to link.

- Select the Hyperlink icon available in the WYSIWYG editor. The Insert/Edit Link dialog box will appear.
  - Select the Internal or External radio button.
  - Navigate to the Internal file
  - Paste the Link to the external file
- Enter a Title which would be the alt tag and appear when a user hovers over the link.
- Click “Insert”

Notes for Accessibility

- Do not use redundant link information.
- Use descriptive text that describes the purpose of the link.
- Convey additional information (type, size, etc.) when linking to documents and files.

Inserting an email address into existing text

- Select a page from the asset tree
- Click the “Edit” tab.
- Locate the Rich Text Editor and select the text you would like to link.

- Select the Hyperlink icon available in the upper toolbar and the Insert/Edit Link dialog box will appear.
- Select the External radio button
- In the “Link” field, type the email address in the format: mailto:email@address.com. “mailto” should precede the actual email address.
- Enter a Title which would be the alt tag and appear when a user hovers over the link.
- Click “Insert”
Chapter 6 - Navigation

Navigation Types
NCAT.edu pages have five navigation types in its page layout.

- **Audience Navigation** – The Audience Navigation links to audience designed pages, is accessible on each page of the site and is not editable.
- **Tactical Navigation** – The Tactical Navigation links to tactical information pages and is accessible on each page of the site.
- **Primary Navigation** – The Primary Navigation links to major university landing pages and is accessible on each page of the site.
- **Ancestor Navigation** (breadcrumbs) - The Ancestor Navigation shows the current location of the user in the content tree. The current page is shown as well as the sequence of parent pages linking back to the home page.
- **Left Column Navigation** – The Left Column Navigation will display the current location in the content tree and will show the selected page’s siblings and children, by default, in the tree structure. The display of the left navigation will follow the Information Architecture of the site. The navigation is dynamic and will automatically display based on the creation of the pages in the CMS.

Navigational Relationships
Relationships are defined by the location of an item within the asset tree structure. These relationships in the asset tree dynamically create the left column navigatoin and the breadcrumbs that are displayed on the website. For example, when a new child page is created it will automatically appear in the left hand navigation and breadcrumb links.

- **Parent** – An asset that contains another asset.
- **Children** – Assets that are contained with another asset.
- **Sibling** – Assets that appear on the same level and have the same parent.
Managing Navigation

Editing the Sort Order of the Left Navigation

- Using the asset tree, browse to the “parent” folder of where you would like to sort the children pages.
- Clicking on the parent folder will default to the “View” tab and “contents” subcategory. A list of all of the children of that folder will display.
- Click on the column header labeled “Order” in the right windowpane.
- Drag and drop the assets until they are in the desired order.
- Selecting an item in folder view gives you sorting options to Send to Top and Bottom or move asset up or down in order by one interval.

Showing/Hiding the Left Navigation

- Using the asset tree, browse to the “parent” folder of where you would like to sort the children pages.
- Clicking on the parent folder will default to the “View” tab and “contents” subcategory.
- Click the “Edit” option.
- Select/Deselect the value of the “Include in Left Navigation” checkbox.
- Click “Submit” to save.

Showing/Hiding individual pages in the Left Navigation

- Using the asset tree, browse to the “parent” folder of where you would like to sort the children pages.
- Clicking on the parent folder will default to the “View” tab and “contents” subcategory.
- Select child page, then Click the “Edit” tab.
- Select the “Configure” tab.
- Select/Deselect the value of the “Include when indexing” checkbox.
- Click “Submit” to save.
Chapter 7 - Publishing

Publishing Assets (for Coordinators)

Publishing is the act of pushing all or individual assets from the development site to the live website. You can publish a page, a folder or a file.

There are several ways to publish assets. From the ... More option in Edit or View, and right clicking on the asset in the asset tree or folder.

These options bring up the Publish dialog box in the main panel. Verify the Publish Mode is set to Publish, then Submit.

Best Practices to prevent broken links or orphaned pages:

- If you have only changed one asset in a folder, only publish the individual asset rather than the folder.
- If assets were deleted, reordered, renamed or moved in a folder, republish the folder, the site’s parent page and the site’s index page.

Un-publishing Assets

If you wish to remove an asset from the live website but not to delete it from the CMS, you would want to Un-publish the asset.

To Un-Publish assets, select the asset, then select the Un-publish radio button.

Un-indexing Assets

To prevent assets in the CMS from being published with other assets in a folder or to remove an asset from site navigation, select the asset, chose the Edit tab in the main panel then the System submenu item.

- Uncheck Public checkbox to exclude the asset from being published when the folder or site is published.
- Uncheck the Index checkbox to remove the asset from being included in the folder’s left navigation.

Note: A site can be published but not indexed, if it needs to exist on the website and in the folder but not be included in the navigation. Just ensure that it is linked from elsewhere on the website to prevent it from being orphaned.
Chapter 8 - Glossary

Glossary of Terms

Header Bar - This buffer between the browser and the rest of Cascade Server houses the sites dropdown, current user, Quick Links, Help, and Log Out links.

Menu Bar - As the primary navigation tool, the menu bar is what ties everything together. The System, Home, and Administration areas are all accessed via the menu bar as well as the New menu used for creating content. History, Tools, Help and Search are also accessible via the menu bar.

Side Bar - The side bar containing the Asset Tree (when in the Home area) or Components (when in the Administration and System areas). The Side Bar can be hidden/shown via the Toggle Side Bar arrow.

Content Area - The primary section of the interface where most work is done. For organization, the content area is divided up and organized by use of tabs and panes (defined below).

Footer Bar - The horizontal blue bar on the very bottom containing copyright and organization information as well as RSS, Home, Menu, and Log Out links.

Asset

An asset is any entity within the system that can be used to generate content. For ease of classification, assets are divided into several different groups:

1. **Page** - This is a mutable asset built by the CMS from other assets to create the finished product of published documents such as web pages or XML documents.

2. **File** - may be a jpeg image, CSS file, or any other static content.

3. **Block** - a "pluggable" piece of content that can be easily substituted, with or without styling, into any page region. As the name suggests, these are the building blocks from which other blocks and pages are built.

4. **Format** - used to transform and style data, such as an XML block

5. **External Link** - a symbolic link to a specific URL

6. **Folder** - a container within Cascade that acts a parent asset to other assets.

7. **Template** - the basic building block for a page's layout.

8. **Reference** - a special asset that is created to represent an existing asset in another location, allowing it to be indexed in multiple folders.

Asset Tree - Displayed in the Side Bar while in the Home area, the Asset Tree shows the hierarchy of assets in the system. Asset trees are also present in the various Administration area component section.

Breadcrumbs - A series of links above the tabs that show the hierarchical path to the open asset.

Dynamic Navigation - Navigation menus on websites are typically a graphical view of a site's hierarchy. When pages are added, deleted, moved, or renamed, all corresponding links need to be updated on the navigation menus throughout the site. Dynamic navigation allows a navigation menu to update automatically, based on the state of a website's content.

Workflow - When creating web content (a page, file, image, etc.), a workflow is a series of ordered steps that the content must go through to be quality-checked, and either approved, modified, or disapproved by the coordinator before being publish-ready.

WYSIWYG Editor - An acronym for "what you see is what you get," the WYSIWYG editor is a word processor-like editor where page content can be added and edited.